safe.utilities.qt module

Qt related helpers.

safe.utilities.qt.qt_at_least(needed_version, test_version=None)[source]

Check if the installed Qt version is greater than the requested

Parameters:
  • needed_version (str) – minimally needed Qt version in format like 4.8.4
  • test_version (int) – Qt version as returned from Qt.QT_VERSION. As in 0x040100 This is used only for tests
Returns:

True if the installed Qt version is greater than the requested

Return type:

bool